Symptom
User is able to connect to the database, but not able to view tables in the Database Painter after upgrading to Windows 7.
Environment
PowerBuilder
Windows 7
Oracle 10g
PowerBuilder O10 Native Driver.
Reproducing the Issue
Only reproducible in customer's environment.
Cause
The user didn't have permission to view the tables even though he was set up as part of the Administrator group.
Solution
Run PowerBuilder as administrator by right clicking on the pbXXX.exe and selecting Run as administrator.
PowerBuilder can also be set up to always run as administrator by doing the following:
1. Right click on the pbXXX.exe and select properties:
2. Select the Compatibility tab and check the Run this program as an administrator checkbox: