DataWindow hangs temporarily after retrieve

Symptom

When accessing a DataWindow in PowerBuilder, the window will pull data and then hang for approximately 30 seconds before continuing to run.

Environment

  • PowerBuilder 2019 R3, 2021

  • Workstations running accessibility software

Reproducing the Issue

In certain environments when opening a DataWindow in a new window that executes a retrieve statement, the data will be retrieved but when the user clicks anywhere in the window the application will freeze for approximately 30 seconds before returning.

Cause

It was determined the cause is due to third party accessibility software running in the background. Specifically DpFbView.dll which is part of the Dell DigitalPersona data protection package.

When third party accessibility software is running in the background it causes PowerBuilder to send accessibility messages, which floods the third party message queue and causes both PowerBuilder and the third party software to hang.

Solution

A flag was added to dynamically turn accessibility messages on or off. In PowerBuilder's initialization path open pb.ini in a basic text editor and add ACCESSIBILITY=0 in the [Application] section of the ini file to turn off accessibility messages.