Accessibility causes slow performance or crash to the application

Symptom

When you open a window that contains a DataWindow, scrolling the data in the DataWindow or closing the window is slow, or even ends with a crash.

Environment

PowerBuilder 2017 R3 (Accessibility defaults to on)

PowerBuilder 2019 R3 (Accessibility defaults to on)

PowerBuilder 2021 (Accessibility defaults to on)

PowerBuilder 2022 or later (Accessibility defaults to off)

Cause

When Accessibility is enabled in the PowerBuilder application, it calls the underlying Windows Accessibility API. Usually, it works well, but in some environments, it causes slow performance or crash in DataWindow.

Resolution

We suggest modifying the pb.ini file as shown below to work around this issue.

Note: If it’s PB 2019 R3, please upgrade to PB 2019 R3 Build 2728 or later before adding or modifying the pb.ini file.

1. If you run application from IDE, open the PB IDE’s pb.ini file, which locates in C:\Users\%username%\AppData\Local\Appeon\PowerBuilder ##.0\pb.ini by default. Add ACCESSIBILITY=0 under the Data Window node and then verify if the issue is solved.

[Application]
ACCESSIBILITY=0

2. If you compile your application to an EXE, then you need to add a pb.ini file to the directory where your PB app.exe resides, and this file contains the following content.

[Application]
ACCESSIBILITY=0

Also, according to the feedback from some customers, if the machine has a touchscreen, disabling the touchscreen service can also solve the issue without modifying the pb.ini file.