Failed to download the InfoMaker Installer

Phenomenon:

When you run InfoMaker Installer from the Web browser or when you run the downloaded InfoMakerInstaller_bootstrapper.exe from the local computer, you may get the following error: "Failed to download the updated InfoMaker Installer. Please check your network connection".

Error message

Cause 1:

The current machine has no Internet connections, or the current machine connects to Internet through a proxy that requires login credentials (which is unsupported by InfoMaker Installer currently).

Solution:

Make sure the current machine has access to the Internet without using a proxy or requiring any login credentials.

If the machine is not allowed to access Internet at all, you can run the InfoMaker offline installer to install the product on this machine. For how to get the InfoMaker offline installer, refer to the section called “Downloading the Offline Installer”.

Cause 2:

The firewall or anti-virus software on the current machine allows access to InfoMakerInstaller_bootstrapper.exe only, but not the other files that are required by InfoMakerInstaller_bootstrapper.exe.

Solution:

Step 1: Try to access https://file.appeon.com/download/Installer/InfoMaker/InfoMakerInstaller.zip in your Web browser.

If you get a "404 File or directory not found" error, then take Step 2 to resolve this error.

Step 2: Configure the firewall and/or the anti-virus software to allow access to https://file.appeon.com/download/Installer/*.

This will allow access to all files that are necessary for running InfoMaker Installer.

Cause 3:

The firewall or anti-virus software does not allow the InfoMaker Installer files (mainly InfoMakerInstaller_setup.exe and InfoMakerInstaller.exe) to access Internet and download files.

Solution:

The InfoMakerInstaller_setup.exe and InfoMakerInstaller.exe files will be first downloaded to the local computer, and then they will need to access Internet to download and install more files. Therefore, you need to make sure the following three files have proper rights to access Internet.

  1. %USERPROFILE%\AppData\Local\Temp\%RarSFX#%\InfoMakerInstaller_setup.exe

    %USERPROFILE%: the current Windows user profile folder, for example, C:\Users\appeon\.

    %RarSFX#%: If there are more than one RarSFX folder, use the one with the largest number at the end of the folder name. For example, C:\Users\appeon\AppData\Local\Temp\RarSFX4.

  2. %AppeonInstallPath%\InfoMaker Installer\update\InfoMakerInstaller_setup.exe

  3. %AppeonInstallPath%\InfoMaker Installer\InfoMakerInstaller.exe

    %AppeonInstallPath%: normally "C:\Program Files\Appeon" in 32-bit Windows and "C:\Program Files (x86)\Appeon" in 64-bit Windows.

    These two files may not exist until after InfoMaker Installer is successfully downloaded. But you can still specify them in the firewall or anti-virus software before they are downloaded.

Step 1: Configure the firewall and/or anti-virus software to allow the above three files to connect to Internet and download files.

The following takes "Windows Defender Firewall with Advanced Security" as an example to show you how to do that.

In Outbound Rules of Windows Defender Firewall with Advanced Security, create new rules with the following settings:

  1. In the Name text box on the General tab, specify a name (for example InfoMakerInstaller_setup) for the rule.

  2. In the Action section on the General tab, select Allow the connection.

  3. In the Programs section on the Programs and Services tab, select This program and specify the absolute path of the file, for example, C:\Users\appeon\AppData\Local\Temp\RarSFX4\InfoMakerInstaller_setup.exe.

  4. Repeat the above three steps to add the second and third rules which point to the absolute path of the following two files respectively:

    • C:\Program Files\Appeon\InfoMaker Installer\update\InfoMakerInstaller_setup.exe (in 32-bit Windows), or

      C:\Program Files (x86)\Appeon\InfoMaker Installer\update\InfoMakerInstaller_setup.exe (in 64-bit Windows)

    • C:\Program Files\Appeon\InfoMaker Installer\InfoMakerInstaller.exe (in 32-bit Windows), or

      C:\Program Files (x86)\Appeon\InfoMaker Installer\InfoMakerInstaller.exe (in 64-bit Windows)

Create the Outbound Rules


Step 2: Run InfoMaker Installer again to verify that the error is resolved.